C Program to find simple interest
Get Principle amount, number of months, rate of interest from user and caluculate simple interest.
Sample Input 1:
5000 12 1.0
Sample Output 2:
600.00
Program or Solution
#include<stdio.h>
int main()
{
int p,n;
double r,si;
scanf("%d %d %lf",&p,&n,&r);
si=(p*n*r)/100;
printf("%.2lf",si);
return 0;
}
Program Explanation
Get principal p, number of months n and rate of intereset r as inputs.
(using scanf statement) calculate Simple Intereset SI by formula SI= p*n*r/100
print Simple Interest SI using printf statement.
Comments
AJAY
i think this program is little tricky oneRelated Programs
- C Program to Addition of two numbers
- C Program to subtraction of two numbers
- C Program to multiply two numbers
- C Program to divide two numbers
- C Program to find modulus of two numbers
- C Program to convert Kilo Meters to Meters
- C Program to convert Meters to Kilo Meters
- C Program to find area of Square
- C Program to find area of Rectangle
- C Program to find area of Right angled triangle
- C Program to find area of triangle
- C Program to find area of Circle (Use Constant)
- C Program to find the distance between two points in 2D space
- C Program to calculate Salary of Employee
- C Program to convert kilobytes to bytes
- C Program to convert bytes to kilobytes
- C Program to calculate Fahrenheit to Celsius
- C Program to calculate Celsius to Fahrenheit
- C Program to Swap two numbers using third variable
- C Program to Swap of two numbers without using third variable
- C Program to print the last digit of given number N
- C Program to toggle a bit in number
- C Program to initialize a variable to zero using XOR Operator
- C Program to Compare M * pow(2,n) and M<<N
- C Program to Compare M divided by pow(2,n) and M>>N
coming Soon
coming Soon