C Program to convert bytes to kilobytes
Get bytes b from user and find kilobytes kb
Sample Input 1:
2048
Sample Output 1:
2
Sample Input 2:
1024
Sample Output 2:
1
Program or Solution
#include<stdio.h>
int main()
{
int bytes;
double kilobytes;
printf("Enter number of bytes:");
scanf("%d",&bytes);
kilobytes=bytes/1024.00;
printf("Kilobytes: %.2lf",kilobytes);
return 0;
}
Program Explanation
Get bytes b as input (using scanf statement)
Calculate kilobytes kb by dividing bytes b by 1024.
(kb=b/1024, 1024 byts is equal to 1 kilobyte)
Print kilobytes kb (using printf statement)
Comments
Related Programs
- C Program to Addition of two numbers
- C Program to subtraction of two numbers
- C Program to multiply two numbers
- C Program to divide two numbers
- C Program to find modulus of two numbers
- C Program to convert Kilo Meters to Meters
- C Program to convert Meters to Kilo Meters
- C Program to find area of Square
- C Program to find area of Rectangle
- C Program to find area of Right angled triangle
- C Program to find area of triangle
- C Program to find area of Circle (Use Constant)
- C Program to find the distance between two points in 2D space
- C Program to calculate Salary of Employee
- C Program to convert kilobytes to bytes
- C Program to find simple interest
- C Program to calculate Fahrenheit to Celsius
- C Program to calculate Celsius to Fahrenheit
- C Program to Swap two numbers using third variable
- C Program to Swap of two numbers without using third variable
- C Program to print the last digit of given number N
- C Program to toggle a bit in number
- C Program to initialize a variable to zero using XOR Operator
- C Program to Compare M * pow(2,n) and M<<N
- C Program to Compare M divided by pow(2,n) and M>>N
coming Soon
coming Soon