C Program to find the distance between two points in 2D space
Get x and y coordinates of two points(x1,y1,x2,y2) and find distance between two points
Sample Input 1:
3 4 4 5
Sample Output 1:
1.414
Flow Chart Design
Program or Solution
#include<stdio.h>
#include<math.h>
int main()
{
int x1,x2,y1,y2;
int x,y; //temporary variables
float distance;
printf("Enter X and Y coordinates of first point");
scanf("%d %d",&x1,&y1);
printf("Enter X and Y coordinates of Second point");
scanf("%d %d",&x2,&y2);
x=x2-x1;
y=y2-y1;
distance=sqrt((x*x)+(y*y));
printf("Distance: %.2f",distance);
return 0;
}
Program Explanation
Get x1,y1,x2 and y2 coordinates of two points(using scanf statement)
Calculate distance by the eculdian distance formula.
Math.sqrt is function available in c library (in math.h header file)to find square root.
Print distance (using printf statement).
Comments
rithik
the program is ease to understand and the flowchart makes this to pickup fastRelated Programs
- C Program to Addition of two numbers
- C Program to subtraction of two numbers
- C Program to multiply two numbers
- C Program to divide two numbers
- C Program to find modulus of two numbers
- C Program to convert Kilo Meters to Meters
- C Program to convert Meters to Kilo Meters
- C Program to find area of Square
- C Program to find area of Rectangle
- C Program to find area of Right angled triangle
- C Program to find area of triangle
- C Program to find area of Circle (Use Constant)
- C Program to calculate Salary of Employee
- C Program to convert kilobytes to bytes
- C Program to convert bytes to kilobytes
- C Program to find simple interest
- C Program to calculate Fahrenheit to Celsius
- C Program to calculate Celsius to Fahrenheit
- C Program to Swap two numbers using third variable
- C Program to Swap of two numbers without using third variable
- C Program to print the last digit of given number N
- C Program to toggle a bit in number
- C Program to initialize a variable to zero using XOR Operator
- C Program to Compare M * pow(2,n) and M<<N
- C Program to Compare M divided by pow(2,n) and M>>N
coming Soon
coming Soon